Microsoft 365 apps and services
Incident Report for Technology Service Desk
Resolved
System Affected
Microsoft 365 apps and services
Issue
Users are unable to view or access Microsoft 365 apps and services on the web.
Actions
A ticket has been created and escalated to Microsoft. Microsoft has reported an issue with its online services. We will continue to look for a workaround to provide access to the apps. No ETA has been established.
Posted Apr 20, 2023 - 13:54 UTC