DISRUPTION - Microsoft 365 services and features
Incident Report for Technology Service Desk
Resolved
RESOLVED

Microsoft 365 services and features

System Affected
Microsoft 365 services and features.
Issue
Users were experiencing service disruption on Microsoft Services such as but not limited to MS Outlook, MS Webmail, MS Teams, OneDrive, and SharePoint.
Actions
The services and features for Microsoft 365 have been restored to normal service levels.
Posted Jun 06, 2023 - 12:50 UTC
Identified
System Affected
Microsoft 365 services and features.
Issue
Users are experiencing service disruption on Microsoft Services such as but not limited to MS Outlook, MS Webmail, MS Teams, OneDrive, and SharePoint.
Actions
Local applications installed on computers continue to work as normal. Microsoft has acknowledged this outage, but no ETA has been established.
Posted Jun 05, 2023 - 16:26 UTC
This incident affected: Microsoft 365.